宝塔面板如何切换宝塔面板PHP版本呢? 推荐先安装PHP,然后再切换PHP,自由切换不同的站点不同的PHP支持

  宝塔面板现支持主流大多数PHP版本,宝塔支持的PHP版本有PHP 5.2/5.3/5.4/5.5/5.6和PHP 7.0/7.1/7.2/7.3。那么如何切换宝塔面板PHP版本呢?

  VPSMVP部落推荐先安装PHP,然后再切换PHP

 

  选择和使用vps服务器的原因也在于可以自定义需要的软件和不同的版本,而只能主机商给我们预设的什么软件版本我们只能使用不可以有其他的要求。同时,我们在使用VPS、服务器的时候,一般都不会只用来建立一个网站,且不同的网站之间软件版本要求有些时候兼容程度是不同的。

 

  有些程序需要兼容PHP7.3,也有些程序兼容PHP5.3这些低端版本。一般我们常用的WEB环境或者面板都可以设置多版本PHP支持的,而且还可以自由切换不同的站点不同的PHP支持。

 

  安装宝塔面板之后,每个程序要求的PHP版不一样,在升级PHP版本之后,导致各种错误,有时候可能是网站主题不支持最新PHP版本。

 

  需要其他兼容版本的话直接对应在”软件管理”中找到PHP版本直接安装。安装需要一点点时间,等待到我们看到已经按照完毕才可以下一步去切换。

 

  安装PHP

  1、登录到宝塔面板后台,地址http://你的服务器ip/8888

  2、点击左侧栏“软件管理”–切换到“运行环境”,即可看到可以安装的PHP版本

  以上就是宝塔面板所有支持的PHP版本有PHP 5.2/5.3/5.4/5.5/5.6和PHP 7.0/7.1/7.2/7.3。

  3、选择需要的PHP版本,点击“安装”即可。

 

  等待,宝塔自动安装。 切换PHP版本 等待宝塔自动安装完毕后,切换PHP版本

 

  1、登录到宝塔面板后台,地址http://你的服务器ip/8888

  2、点击左侧栏“网站”,找到目标网站,点击网站域名右侧的“设置”

  3、在网站设置中,找到“PHP版本”,选择想要的PHP版本,点切换即可

 

  最后发现要设置切换PHP版本,具体方法如下:

  点击左侧菜单“网站”>> 点击对应网站右侧的“设置”按钮 >> 点击左侧的“PHP 版本”>> 在 PHP 版本下拉选项中选择对应的PHP版本 >> 点击【切换】按钮即可,稍等片刻即可成功切换 PHP 版本。

 

答疑

可以多版本同时存在  网站->设置->PHP版本

把各种版本的PHP都安装上去,然后在网站设置那,可以指定哪个网站使用哪个PHP版本

Q:安装了更高版本的php会不会影响其他的网站运行?
A: 每个网站都是可以选择指定的php版本的。你安装了更高版本,如果没有在网站设置里更改PHP版本的话,这些网站都还是使用你安装新版本之前的版本的。

赞(0) 打赏
需要国外VPS建站朋友,请联系站长! 转载请注明文章来源:VPSMVP部落 - 便宜VPS|VPS优惠|VPS测评|美国VPS|VPS教程 » 宝塔面板如何切换宝塔面板PHP版本呢? 推荐先安装PHP,然后再切换PHP,自由切换不同的站点不同的PHP支持
分享到: 更多 (0)

评论 抢沙发

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址

觉得文章有用就打赏一下文章作者

支付宝扫一扫打赏

微信扫一扫打赏




友情链接:
 |  博客之家  |  搜狗网址导航  |  百万网址导航  |  网址导航  |  赵容部落  |  老左笔记  |  微魔部落  |  国外主机测评  |  便宜VPS  |  vps小学生  |  国外主机测评  |  主机百科  |  vps精选网  |  小夜博客  |  国外便宜VPS  |  VPS大学  |  veidc测评

卢松松博客 友情链接申请